iPhone 3GS 3Gs jailbreak

Discussion in 'iPhone' started by danward, Oct 5, 2009.

  1. danward

    danward New Member

    Joined:
    Feb 15, 2009
    Messages:
    12
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    OK so now I'm confused.

    I'm getting a 3gs with 3.0 on it factory unlocked and I want to know after you back up the id's with sauriks server can you jailbreak on any firmware? Or is it only jailbreakable on firmwares they have found holes in the IBSS file?
    eg if there is no boot hole in 3.2 can we not jailbreak it? or do we use the IBSS from 3.0 in the 3.2 file?

    Also can saurik still get device SHSH's from 3.0 if I go on cydia? Meaning he will have my device 3.0 SHSH on back up?

    Thanks,
    Daniel
  2. DrewGzy

    DrewGzy Active Member

    Joined:
    Dec 11, 2007
    Messages:
    1,205
    Likes Received:
    10
    Once you have your 3.0 ECID uploaded to Cydia (or your own server if you want) you can safely upgrade to a custom firmware. If you do a factory upgrade to 3.1 you won't be able to jailbreak it but you can downgrade to 3.0 (thanks to your ECID being on Saurik's site). If you upgrade to 3.1 without having your ECID somewhere "safe" I believe you will lose the ability to downgrade (possibly forever).

    To get your ECID onto Cydia you will have to follow Saurik's guide; There is a link to it on the first post on this thread.
  3. danward

    danward New Member

    Joined:
    Feb 15, 2009
    Messages:
    12
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Thanks, that answers everything but if you have the 3.0 ECID on file can you jailbreak any firmware or only the ones with boot holes in them?

    Thanks,
    Daniel
  4. DrewGzy

    DrewGzy Active Member

    Joined:
    Dec 11, 2007
    Messages:
    1,205
    Likes Received:
    10
    This is only a slightly educated guess but by saving the 3.0 ECID to Cydia future firmwares will be vulnerable because the "signature" that Apple tries to verify will actual be coming from Cdyia.

    This is assuming that a future firmwares will be vulnerable to a jailbreak (which they all have been so far but it may take some time).

    Not sure if that answers your question but hopefully it helps.
  5. sbbb61

    sbbb61 New Member

    Joined:
    Jun 1, 2008
    Messages:
    18
    Likes Received:
    0
    I believe you have to jb on lower fw (ie. 3.0 or 3.01) before you can safely jb/update to 3.1
  6. danward

    danward New Member

    Joined:
    Feb 15, 2009
    Messages:
    12
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Thanks, so basically they have to have to be vulnerable to a jailbreak even if the device is jb'd. Yep that answers it. Thanks.
  7. Number8

    Number8 New Member

    Joined:
    Sep 12, 2009
    Messages:
    424
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Well you have to jailbreak to 3.1 first. Saurik can't sign 3.0 firmware anymore, only the lucky ones who backed up their 3.0 ECID a while ago can. Now you just have to either have a Mac or wait for a 3.1 jailbreak to back up your 3.1 ECID.
  8. danward

    danward New Member

    Joined:
    Feb 15, 2009
    Messages:
    12
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    I got a mac and have a pwnage IPSW ready. can you use umbrella to get a 3.0 still? cause i used one and got a positive one from Apples server.
    Thanks,
    Daniel

Share This Page