3.1.3 spirit jb ipod touch bricked?

Discussion in 'iPod touch' started by bakofritz, Jun 8, 2010.

  1. bakofritz

    bakofritz New Member

    Joined:
    Jun 7, 2010
    Messages:
    1
    Likes Received:
    0
    Hi, hope I'm not reposting. I've been searching for a while and tried, I think everything.

    I have an MC model ipod touch 3.1.3 fw. I used spirit and was working fine. The other night, I went to erase everything to factory settings within the ipod menu just to clean it out. I have done this before with no problem.

    Went to check progress, and the screen was frozen with the loading circle thing stuck. So I reset it.

    Now when I start it up, it goes to the apple with the loading wheel and freezes.

    I have tried itunes restore a few hundred times with error 1604. Tried connection with several different apps as well with no luck.

    Would someone please help me troubleshoot this? I'm getting frustrated. Thanks and God bless.
  2. xFKSxSquirrel

    xFKSxSquirrel Member

    Joined:
    Apr 9, 2008
    Messages:
    892
    Likes Received:
    0
    Device:
    2G iPod touch
    go into dfu mode and restore then rejailbreak

Share This Page