3.1.2 iphone needs to be upgraded

Discussion in 'iPhone' started by steelers760, Sep 18, 2010.

  1. steelers760

    steelers760 New Member

    Joined:
    Sep 1, 2008
    Messages:
    8
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    I currently have an unlocked iphone 3Gs 16gb running on 3.1.2 which I jailbroke with blackra1n, and i need to upgrade my phone at least to 3.1.3 because I have the NFL sunday ticket and the app needs 3.1.3 at least to run. Is there a way to update my phone to at least 3.1.3 without losing my unlock because I am on T-mobile network. Is there a way to do this without using a ATT sim card since I do not know anybody with an ATT sim card.
  2. iRa1n

    iRa1n Banned

    Joined:
    Jul 15, 2010
    Messages:
    814
    Likes Received:
    0
    Device:
    2G iPod touch
    Considering you are jailbroken, go to system/library/coreservices and find system version.plist change the top number (should be 7D11) to 7E18 and then change 3.1.2 to 3.1.3 and then reboot. Seeming as there were no major changes between 3.1.2 and 3.1.3 just making it think it is 3.1.3 should make your app work.
  3. steelers760

    steelers760 New Member

    Joined:
    Sep 1, 2008
    Messages:
    8
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    Will i lose my unlock if I do this??
  4. iRa1n

    iRa1n Banned

    Joined:
    Jul 15, 2010
    Messages:
    814
    Likes Received:
    0
    Device:
    2G iPod touch
    all this is doing is changing what the phone displays as the firmware version. So no.
  5. Imariel

    Imariel New Member

    Joined:
    Jun 22, 2010
    Messages:
    203
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    I could've sworn there was a package that did this on BigBoss...but yeah, editing that file is the way to go.
  6. guy123456

    guy123456 Member

    Joined:
    Nov 8, 2009
    Messages:
    919
    Likes Received:
    1
    w8, i have 3.1.3 can i do this to run 4.0 apps?
  7. iRa1n

    iRa1n Banned

    Joined:
    Jul 15, 2010
    Messages:
    814
    Likes Received:
    0
    Device:
    2G iPod touch
    Nah you cant. The only reason i say to do this is that 3.1.2 and 3.1.3 have almost no difference at all. 3.1.3 was made to patch the exploit blackra1n used. 3.1.2/3.1.3 ; almost exactly the same, 3.1.3/4.0 ; major changes.
  8. guy123456

    guy123456 Member

    Joined:
    Nov 8, 2009
    Messages:
    919
    Likes Received:
    1
    i see. well, i guess it was worth a try
  9. ThePodofi

    ThePodofi Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    4,355
    Likes Received:
    958
    amen brother^

Share This Page