3.1.1

Discussion in 'iOS Development' started by hackpro1989, Sep 19, 2009.

  1. hackpro1989

    hackpro1989 Member

    Joined:
    Mar 8, 2008
    Messages:
    96
    Likes Received:
    0
    Device:
    iPhone 4S (White)
    My App that was build for 3.0 is no longer working due to the 3.4 xcode update how can i get 2.2.1 support back ?
  2. SkylarEC

    SkylarEC Super Moderator Emeritus Staff Member

    Joined:
    Sep 19, 2007
    Messages:
    6,642
    Likes Received:
    129
    Set the base SDK for that project to 2.2.1. Although, at this point, I wouldn't focus too much energy on the 2.2.1 firmware; instead focusing on updating the application to work with the 3.1/.1 firmware.
  3. hackpro1989

    hackpro1989 Member

    Joined:
    Mar 8, 2008
    Messages:
    96
    Likes Received:
    0
    Device:
    iPhone 4S (White)
    It Says It's Missing apple took support out for 10.6 Users
  4. bddckr

    bddckr Active Member

    Joined:
    Dec 2, 2007
    Messages:
    1,434
    Likes Received:
    18
    Device:
    iPhone 4 (Black)

    Please Register or Log in to view images


    I suggest you download the latest iPhone SDK Installer for Snow Leopard.
  5. NolesFans

    NolesFans New Member

    Joined:
    Sep 23, 2008
    Messages:
    404
    Likes Received:
    0
    Device:
    iPod touch
    It also said "You can't run 2.2.1 application in the Stimulator."
  6. gojohnnyboi

    gojohnnyboi Well-Known Member

    Joined:
    Jan 25, 2008
    Messages:
    3,339
    Likes Received:
    55
    Xcode 3.4 update? What? I thought it was 3.2, or was that a typo?
  7. bddckr

    bddckr Active Member

    Joined:
    Dec 2, 2007
    Messages:
    1,434
    Likes Received:
    18
    Device:
    iPhone 4 (Black)
    Mine says this:

    Please Register or Log in to view images

  8. cocotutch

    cocotutch Community Development Team Staff Member

    Joined:
    Oct 6, 2008
    Messages:
    1,285
    Likes Received:
    117
    Device:
    5G iPod touch
    Mount the DMG and click Customize during the Install after clicking Continue etc.... As of the 3.1 SDK Apple automatically unticked the 2.0 and 2.2.1 SDKs in the Installer. You will not be able to run 2.2.1 apps in the Simulator, but you will be able to debug on the Device.

    cocotutch

    EDIT: Dang, ChriB beat me to it.

Share This Page