3.0 Requires Newer Version of iTunes?

Discussion in 'iPod touch Firmware 3.0' started by w1nner, Jun 17, 2009.

  1. w1nner

    w1nner New Member

    Jun 17, 2009
    Likes Received:
    2G iPod touch
    i have windows xp pro 64 bit which officially the ipod touch is not compatible with. luckily i found a special package that somebody else made which allows you to sync and use your ipod touch on 64 bit xp. however the version of this pack is unfortunatly you need a newer version which i think would fawk up my setup. lets say i used a different computer to upgrade to 3.0... if i tryed syncing my ipod with my xp 64 bit comp after upgrading would it still work?

Share This Page