3.0 iPod Software with 1st Gen. Touch?

Discussion in 'iPod touch' started by Thomas-J, Sep 8, 2009.

  1. Thomas-J

    Thomas-J New Member

    Joined:
    Sep 8, 2009
    Messages:
    43
    Likes Received:
    0
    Device:
    iPod touch
    Is it worth getting the iPod 3.0 Software if I have a 1st generation iPod Touch?
  2. LssThanThree

    LssThanThree Active Member

    Joined:
    Jan 21, 2009
    Messages:
    1,943
    Likes Received:
    3
    Device:
    iPhone 5 (Black)
    If you want Copy/Paste, go for it!
    lol
  3. TouchedApps

    TouchedApps New Member

    Joined:
    Aug 11, 2009
    Messages:
    24
    Likes Received:
    0
    Device:
    iPod touch
    Yea, It has alot of features. Go For It!

    Search..
    Copy / Paste..
  4. traxxy

    traxxy New Member

    Joined:
    Jan 6, 2008
    Messages:
    41
    Likes Received:
    0
    Device:
    iPod touch
    copy / paste??? :S what does that mean

    Anyway, I got a 1st gen and I did upgrade to 3.0, in my opinion it's not really a better firmware, personally I wouldn't spend money on it so all I say to you is: "the 3.0 firmware is downloadable from the internet

    Please Register or Log in to view images

    "
  5. ThetaSigma

    ThetaSigma New Member

    Joined:
    Jun 27, 2009
    Messages:
    45
    Likes Received:
    0
    Device:
    4G iPod touch
    i found that my battery goes down at double the speed. i only keep it cos of support and i can runs gpsphone at full speed

    Please Register or Log in to view images

  6. sjleworthy

    sjleworthy New Member

    Joined:
    Jan 4, 2008
    Messages:
    780
    Likes Received:
    0
    Device:
    iPad w/ 3G
    we updated our 2nd gen in work to 3.0 and lost 99% of wi-fi coverage, both at home and in work. cant connect to hardly any ware now.

    so no, for me personally my own 1st gen will be without 3.0 until that particular bug gets fixed.
  7. Thomas-J

    Thomas-J New Member

    Joined:
    Sep 8, 2009
    Messages:
    43
    Likes Received:
    0
    Device:
    iPod touch
    Well thanks for all the info. It looks like I won't be getting the 3.0 software.
  8. JOS

    JOS Member

    Joined:
    Jan 28, 2008
    Messages:
    522
    Likes Received:
    3
    Device:
    iPhone 5 (Black)
    However, before that is truly your final decision.. you should know that the upcoming apps will eventually stop being compatible with 2.0 FW. The wave of the future moves on, leaving old technologies from time to time.

    Please Register or Log in to view images

  9. sjleworthy

    sjleworthy New Member

    Joined:
    Jan 4, 2008
    Messages:
    780
    Likes Received:
    0
    Device:
    iPad w/ 3G
    yes, more and more apps and games are only 3.0 compatible.

    personally for me wi-fi connectivity is more important than downloading a new app. but hopefully Apple will fiz this bug soon.
  10. Thomas-J

    Thomas-J New Member

    Joined:
    Sep 8, 2009
    Messages:
    43
    Likes Received:
    0
    Device:
    iPod touch
    So has the Wi-Fi connectivity issue been fixed with the 3.1 software?

Share This Page