3.0 Install Problem

Discussion in 'iPod touch Firmware 3.0' started by hommerxxx, Aug 11, 2009.

  1. hommerxxx

    hommerxxx New Member

    Joined:
    Aug 11, 2009
    Messages:
    1
    Likes Received:
    0
    Device:
    2G iPod touch
    I can install the last version before 3.0 firmware just fine. But everytime i try to install 3.0 my ipod touch 2g gets an error and i need to restore. Im not using a mac to do so, is there a difference?
  2. Jack Bauer

    Jack Bauer Member

    Joined:
    Nov 30, 2008
    Messages:
    868
    Likes Received:
    0
    Device:
    iPod touch
    No but try updating your itunes then try it again
  3. DazedUp

    DazedUp New Member

    Joined:
    Aug 3, 2009
    Messages:
    110
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    you need latest version of iTunes to update to 3.0

Share This Page