2.2 firmware jailbreak?

Discussion in 'iPod touch 2G Jailbreak: redsn0w, 24kpwn, etc.' started by eric8205, Feb 16, 2009.

  1. eric8205

    eric8205 New Member

    Joined:
    Nov 28, 2008
    Messages:
    112
    Likes Received:
    0
    Device:
    4G iPod touch
    Can the iPod touch second generation be jailbroken when it's at the 2.2 software because I have read that it only works on the 2.1.1 is this true? I have been waiting along time for thisplease tell me that it is possible!
    Also I had a quick question, if the 2.2 can be jailbroken which would you suggest a new person to jailbreaking (as I have only owned a second gen and have not yet jailbroken) the tethered or semi tethered. I have heard that the semi thethered is easier although I have heard that it is very slow and crashy. If there is any truth to this would you recomend the harder more reliable version or the easier version?
  2. mitchell209

    mitchell209 Active Member

    Joined:
    Jan 21, 2009
    Messages:
    8,024
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    No, Semi-Tethered is not easier if you dont' know what you're doing. Just go with the Tethered, it's more stable, and has many GUIs for you to use.

    And you can jailbreak if your firmware is 2.2.1
  3. eric8205

    eric8205 New Member

    Joined:
    Nov 28, 2008
    Messages:
    112
    Likes Received:
    0
    Device:
    4G iPod touch
    2.2.1?

    How. Do I know if it is 2.2.1 when I check it it just says 2.2 is that the right firmware, can I jailbreak?
  4. .xLr8™

    .xLr8™ New Member

    Joined:
    Nov 18, 2008
    Messages:
    1,396
    Likes Received:
    0
    yes you can - obama
  5. eric8205

    eric8205 New Member

    Joined:
    Nov 28, 2008
    Messages:
    112
    Likes Received:
    0
    Device:
    4G iPod touch
    2.2.1?

    How. Do I know if it is 2.2.1 when I check it it just says 2.2 is that the right firmware, can I jailbreak?
    ------------------double post merged------------------
    How. Do I know if it is 2.2.1 when I check it it just says 2.2 is that the right firmware, can I jailbreak?

Share This Page