2.2.1 Firmware Games to 3.0 Firmware - Compatability

Discussion in 'iPod touch' started by PatentPending, Jul 13, 2009.

  1. PatentPending

    PatentPending New Member

    Joined:
    Jun 6, 2009
    Messages:
    48
    Likes Received:
    0
    Device:
    2G iPod touch
    I've been thinking about upgrading my happily jailbroken 2nd Generation iPod Touch to the new 3.0 firmware. Problem is, I have literally hundreds of apps and games made for 2.2.1 firmware. If I upgrade to 3.0, jailbreak that again, will all my apps/games be compatible with the new firmware? Or will only the ones that recently made themselves compatible work? It would really blow if I'd end up losing many, if not all my games and such because of incompatability. I'm just hoping that when an app says it's now compatible with 3.0 firmware, it's just saying it utilizes some of the new features like P2P or Bluetooth. And will themes be a problem too? I'm currently using iNitsua Landscape, most recent version.
  2. bjlock

    bjlock Member

    Joined:
    Oct 26, 2007
    Messages:
    415
    Likes Received:
    5
    Device:
    iPhone 5 (White)
    just check for updates in itunes; and they will be compatible with the new 3.0 firmware
  3. PatentPending

    PatentPending New Member

    Joined:
    Jun 6, 2009
    Messages:
    48
    Likes Received:
    0
    Device:
    2G iPod touch
    That's the thing. The majority of the games and apps still haven't come out with a compatible version. I'm trying to search through Cydia to see if there's some sort of compatibility hack or something I can use later.
  4. Nburnes

    Nburnes Well-Known Member

    Joined:
    Jan 3, 2009
    Messages:
    9,023
    Likes Received:
    767
    Device:
    OnePlus One
    2.2.1 apps are supposed to work on 3.0 anyway....
  5. PatentPending

    PatentPending New Member

    Joined:
    Jun 6, 2009
    Messages:
    48
    Likes Received:
    0
    Device:
    2G iPod touch
    See? That's the response I was hoping for, but I'm just making sure I don't end up losing things in the end. I'll probably upgrade soon. If anything, I could just downgrade. Thanks, Nb
  6. sean222

    sean222 New Member

    Joined:
    Oct 19, 2007
    Messages:
    24
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    I lost all of my save games when going to 3.0...maybe I did something wrong

    Please Register or Log in to view images

    I manually backed up /var/mobile/Applications for the games with high scores I wanted to keep...but I guess my mistake was that the save games aren't kept there

    Please Register or Log in to view images



    As for compatibility, I'd say 95% of all my games/apps worked.
  7. PatentPending

    PatentPending New Member

    Joined:
    Jun 6, 2009
    Messages:
    48
    Likes Received:
    0
    Device:
    2G iPod touch
    That's EXACTLY what I was worried about! But I guess 95% is something I can live with. But the saves.... ehh, I'll probably not care much...
  8. iTouchGuru

    iTouchGuru New Member

    Joined:
    Jun 27, 2009
    Messages:
    393
    Likes Received:
    0
    Device:
    2G iPod touch
    On 3.0, all 1.1.1, 1.1.2, 1.1.3 - 2.2.1 apps are still compatible.

    3.0 just makes it so more apps BECOME compatible.

    Like if one of your apps updates, and only becomes compatible with 3.0, then you would need 3.0. But all 3.0 does is update the SDK, but it keeps all changes made.

    So if an app says "Needs 2.2.1 software update", it will be compatible with 3.0

    I hope im being clear here.
  9. PatentPending

    PatentPending New Member

    Joined:
    Jun 6, 2009
    Messages:
    48
    Likes Received:
    0
    Device:
    2G iPod touch
    Crystal Clear! I was worried "I" was the one not being clear enough but it seems like you answered my question perfectly. Thanks a lot since now I feel confident enough to upgrade to 3.0

Share This Page