2.1 app on 2.0.2

Discussion in 'iPod touch Firmware 2.X' started by mackattack2324, Oct 20, 2008.

  1. mackattack2324

    mackattack2324 New Member

    Joined:
    Apr 4, 2008
    Messages:
    67
    Likes Received:
    0
    Device:
    iPod touch
    is it possible to run a 2.1 app on 2.0...for example jelly car. is there anyway i could download it or do i have to upgrade to 2.1......by the way the reason i dont want to upgrade is that my comp is pretty f'ed up so when i upgrade it erases everything on my ipod..
  2. JonnySK

    JonnySK Active Member

    Joined:
    Apr 20, 2008
    Messages:
    1,767
    Likes Received:
    5
    Device:
    2G iPod touch
    Yes, a 2.1 app will work on 2.0/2.0.1/2.0.2
    But not 1.1.x
  3. SkylarEC

    SkylarEC Super Moderator Emeritus Staff Member

    Joined:
    Sep 19, 2007
    Messages:
    6,642
    Likes Received:
    129
    There are differences within the two firmwares. A 2.1 app may work on 2.0 - 2.0.2, but there are no guarantees. Just like there were no guarantees a 1.1.4 app would work on 1.1.1. That's just the way things are.

    Now, with that in mind, unless you specifically designate 2.1, Apple limits an app to the SDK that the coder uses. For example, my apps, I use the most recent SDK, which is 2.1. Apple will tell you that the app is for 2.1 only, but they should also work with 2.0 - 2.0.2.

    Your milage will vary.
  4. mackattack2324

    mackattack2324 New Member

    Joined:
    Apr 4, 2008
    Messages:
    67
    Likes Received:
    0
    Device:
    iPod touch
  5. iPTF_BROWSER

    iPTF_BROWSER Active Member

    Joined:
    Aug 17, 2008
    Messages:
    1,623
    Likes Received:
    20
    Device:
    HTC One
    WRONG. 2.1 apps only work with the firmware 2.1. That is why it says 2.1 is required when you try to download a 2.1 app. Even if you change the string to say it is on 2.1 they will just crash.
  6. SkylarEC

    SkylarEC Super Moderator Emeritus Staff Member

    Joined:
    Sep 19, 2007
    Messages:
    6,642
    Likes Received:
    129
    Obviously, you missed my post in this thread.
  7. rokrboy

    rokrboy Retired Moderator

    Joined:
    Sep 29, 2007
    Messages:
    2,475
    Likes Received:
    29
    Device:
    iPod touch
    Dude, only apps specifically dedicated to 2.1, which there are few for right now will not run on 2.0-2.02. Most apps are written so that they will work on many variations of a software, in this case being iphone/ipod touch.
    Thats why skylar explained that:
  8. SeeFreaky

    SeeFreaky New Member

    Joined:
    Mar 21, 2008
    Messages:
    596
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    well, i downloaded lightsaber Unleashed, and MazeFinger on my iPod Touch, which is still on firmware 2.0.1. I just used FWChanger on Cydia.
  9. ryanlusk

    ryanlusk Banned

    Joined:
    May 17, 2008
    Messages:
    2,706
    Likes Received:
    0
    Why don't you just actually upgrade to 2.1 ?

    It wouldn't be that hard to get your sh*t on the iPod would it ?
  10. sprint_user

    sprint_user New Member

    Joined:
    Apr 27, 2008
    Messages:
    2,864
    Likes Received:
    1
    Device:
    iPad 2 (Black)
    I would just update anyway, 2.1 has a lot of bug fixes, including better battery life. 2.0.2 had bad battery life when I had my 1g, I would just update

Share This Page