1G iTouch Help!

Discussion in 'Introduce yourself' started by homeschoolsyd, Oct 9, 2010.

  1. homeschoolsyd

    homeschoolsyd New Member

    Joined:
    Oct 9, 2010
    Messages:
    1
    Likes Received:
    0
    I just got a 32gb 1st Gen iTouch off Ebay as a Christmas gift for my special needs son.
    Apparently all the apps need a more current OS?
    I'm running iTunes V 10 dot whatever, the OS on the iTouch is v2.2.1
    From what I've been able to glean so far - I need to update/upgrade it to a v3.1... but the downloads I have tried said they are not compatible with the device.

    This is the first anything mac I've owned - and we're talking mostly children's games/apps here. Can anyone provide guidance? Is this upgrade-able or...?
    THanks
    Noah's Mom

    Please Register or Log in to view images

  2. Tkf1

    Tkf1 Community Development Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    17,397
    Likes Received:
    2,488
    Device:
    iPad mini
    Download 3.1.3 for the iPod Touch 1gen. Or press update in iTunes.
  3. link07

    link07 Active Member

    Joined:
    Jun 15, 2010
    Messages:
    1,612
    Likes Received:
    3
    Device:
    4G iPod touch
    ^ I agree try the above!!
  4. Unregistered

    Unregistered Guest

    I had done that first guys, and it says that it isn't compatible with the device.

    Any other ideas???
  5. Tkf1

    Tkf1 Community Development Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    17,397
    Likes Received:
    2,488
    Device:
    iPad mini
    Are you using 1,2XXXX IPSW?

Share This Page