1604 Error? Stuck in Recovery Mode? Read this!!

Discussion in 'iPod touch' started by Royston, May 18, 2010.

  1. Royston

    Royston New Member

    Joined:
    May 18, 2010
    Messages:
    1
    Likes Received:
    0
    Device:
    2G iPod touch
    Hi,

    I recently had a scare with my new jailbroken ITouch 2g 8Gb running 3.1.3 FW. I wanted to un-jailbreak it and downgrade to 3.1.2 and that's where my problems began.

    Tried restoring in DFU mode several times but that didn't help!

    1)The device got stuck in recovery mode and wouldn't boot up
    2)If I tried to restore it with the 3.1.3 ipsw I got the dreaded 1604 error
    3)If I tried the restore it with 3.1.2 ipsw I got the 1601 error
    4)If I tried to restore with 3.0 i got error 20.


    Went through literally hundreds of posts on this site and nothing seemed to be working.

    Here's what worked for me:
    1. Connect the device to iTunes, confirm that the device is in Recovery Mode. If it's not in Recovery Mode, put it into Recovery Mode.
    2. Restore and wait for error 1604.
    3. When prompted, click OK.
    4. Close and re-open iTunes while iPhone remains connected.
    5. iPhone should now be recognized in Recovery Mode again.
    6. Try to restore again.

    This is directly from the Apple Support page:
    http://support.apple.com/kb/TS1275

    Hope this helps a little.

Share This Page