1.1.5 Help, Please?

Discussion in 'iPod touch Firmware 1.1.5 Discussions' started by bubs58, Jul 22, 2008.

  1. bubs58

    bubs58 Member

    Joined:
    Dec 31, 2007
    Messages:
    594
    Likes Received:
    2
    Device:
    iPod touch
    Can i downgrade 2.0 to 1.1.5, im extremely sorry if theres already a thread on this and if there is ill delete this one right away...

    Anyways can i downgrade? and how?
  2. Totally 1337

    Totally 1337 Active Member

    Joined:
    Mar 27, 2008
    Messages:
    3,966
    Likes Received:
    17
    Device:
    iPhone 4S (Black)
    yes but you need iTunes 7.5

    remember to search!!!

    Please Register or Log in to view images

  3. 11hawkinst

    11hawkinst New Member

    Joined:
    Oct 13, 2007
    Messages:
    36
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
  4. bubs58

    bubs58 Member

    Joined:
    Dec 31, 2007
    Messages:
    594
    Likes Received:
    2
    Device:
    iPod touch
    So i downgrade to itunes 7.5, put my ipod into DFU and then shift click the 1.1.5 restore file?
  5. GNARDOG

    GNARDOG New Member

    Joined:
    May 4, 2008
    Messages:
    45
    Likes Received:
    0
    Device:
    iPod touch
    looks like apple got you by the balls son.just like that *** steve jobs likes it.i like apple for the ipods but that's about it.i got 1.1.5 and installed fw changer to immediately go back to 1.1.4.

Share This Page