Apple Reveals Game Center Compatibility

Apple has just added a Game Center page to their website, outlining the features of the service and what iOS devices it is available on. The good news is that it will work on 2nd gen and newer iPod Touches, but iPhone 3g owners are out of luck, and will need to upgrade to a newer model to take advantage of Game Center. There were rumors that Apple nixed the service from older devices when iPod Touch 2g and iPhone 3g support was removed in the iOS 4.1 beta 3, but it looks like they changed their minds on one account.

If you have been testing out Game Center in the iOS 4.1 beta, then you have probably had your account reset by Apple, so you will need to recreate it when you update to the official version of 4.1

[Mac Rumors]

Post a response / What do you think?