Sn0wbreeze 1.8 Released for iOS 4.1

iH8sn0w has updated his jailbreaking tool to support the iOS 4.1 developer beta. Supported devices include the following: Pre-jailbroken iPod Touch 2g, 3g, and iPhone 3gs. iPhone 3g and non-MC model iPod Touch 2g users can use redsn0w.

sn0wbreeze V1.8 BETA – http://bit.ly/dlO3Lu <– Jailbreaks 4.1 BETA Pre-jailbroken on 4.x. Supports ipt2g/ipt3/3GS.

[iH8sn0w]

And here is a tutorial on how to use the newest sn0wbreeze from Redmond Pie.

Post a response / What do you think?